ZenTao and PHP 8.1
2021-12-23 08:34:17
Andrey
  • Visit: 13
  • Join Date: 2021-03-07
  • Last Login: 2022-04-14
  • My Point: 0
  • PartyLevel: No Party
Is there any way to install ZenTao on php 8.1?
Error log:

2021/12/23 02:54:42 [error] 22619#22619: *17 FastCGI sent in stderr: "PHP message: PHP Fatal error:  $GLOBALS can only be modified using the $GLOBALS[$name] = $value syntax in /www/xxx.dev/framework/base/router.class.php on line 623" while reading response header from upstream, client: xxx.xxx.xxx.xxx, server: xxx.dev, request: "GET /index.php?m=user&f=login&referer=Lw== HTTP/1.0", upstream: "fastcgi://unix:/run/php-fpm/www.sock:", host: "xxx.dev"


2022-01-28 13:53:41
philip
  • Visit: 2431
  • Join Date: 2018-10-18
  • Last Login: 2022-08-12
  • My Point: 0
  • PartyLevel: No Party
Please install the latest version of ZenTao which has already supported the PHP8.1
2022-02-07 06:57:44 Reply #1
Andrey
  • Visit: 13
  • Join Date: 2021-03-07
  • Last Login: 2022-04-14
  • My Point: 0
  • PartyLevel: No Party
Post by philip on 2022-01-28 13:53:41

Please install the latest version of ZenTao which has already supported the PHP8.1

Great! Thanks!

#3
2022-05-07 02:46:36
jJQaBOcg
  • Visit: 3
  • Join Date: 2019-02-06
  • Last Login: 2022-05-07
  • My Point: 0
  • PartyLevel: No Party
1
#4
2022-05-07 02:46:36
jJQaBOcg
  • Visit: 3
  • Join Date: 2019-02-06
  • Last Login: 2022-05-07
  • My Point: 0
  • PartyLevel: No Party
1
#5
2022-05-07 02:48:02 Reply #2
jJQaBOcg
  • Visit: 3
  • Join Date: 2019-02-06
  • Last Login: 2022-05-07
  • My Point: 0
  • PartyLevel: No Party
Post by Andrey on 2022-02-07 06:57:44 Reply #1
Post by philip on 2022-01-28 13:53:41

Please install the latest version of ZenTao which has already supported the PHP8.1


Great! Thanks!

#6
2022-05-07 02:48:03 Reply #2
jJQaBOcg
  • Visit: 3
  • Join Date: 2019-02-06
  • Last Login: 2022-05-07
  • My Point: 0
  • PartyLevel: No Party
Post by Andrey on 2022-02-07 06:57:44 Reply #1
Post by philip on 2022-01-28 13:53:41

Please install the latest version of ZenTao which has already supported the PHP8.1


Great! Thanks!

#7
2022-05-07 02:48:03 Reply #2
jJQaBOcg
  • Visit: 3
  • Join Date: 2019-02-06
  • Last Login: 2022-05-07
  • My Point: 0
  • PartyLevel: No Party
Post by Andrey on 2022-02-07 06:57:44 Reply #1
Post by philip on 2022-01-28 13:53:41

Please install the latest version of ZenTao which has already supported the PHP8.1


Great! Thanks!

#8
2022-05-07 02:48:03 Reply #2
jJQaBOcg
  • Visit: 3
  • Join Date: 2019-02-06
  • Last Login: 2022-05-07
  • My Point: 0
  • PartyLevel: No Party
Post by Andrey on 2022-02-07 06:57:44 Reply #1
Post by philip on 2022-01-28 13:53:41

Please install the latest version of ZenTao which has already supported the PHP8.1


Great! Thanks!

#9
2022-05-07 02:48:03 Reply #2
jJQaBOcg
  • Visit: 3
  • Join Date: 2019-02-06
  • Last Login: 2022-05-07
  • My Point: 0
  • PartyLevel: No Party
Post by Andrey on 2022-02-07 06:57:44 Reply #1
Post by philip on 2022-01-28 13:53:41

Please install the latest version of ZenTao which has already supported the PHP8.1


Great! Thanks!

#10
2022-05-07 02:48:03 Reply #2
jJQaBOcg
  • Visit: 3
  • Join Date: 2019-02-06
  • Last Login: 2022-05-07
  • My Point: 0
  • PartyLevel: No Party
Post by Andrey on 2022-02-07 06:57:44 Reply #1
Post by philip on 2022-01-28 13:53:41

Please install the latest version of ZenTao which has already supported the PHP8.1


Great! Thanks!

1/12